Update on Celebrity's engine problems

Nov 5th, 2002, 05:38 PM
  #1  
Lori
Guest
 
Posts: n/a
Update on Celebrity's engine problems

Does anyone have information on Celebrity's engine pod problems? They have had a lot of problems in the past with their newer ships having bearing trouble. Specifically, I am cruising on the Summit this February, and I would like to find out the progress with the repairs they are making. Our last cruise was cancelled due to this problem. If anyone has info or a website I can check for updates, I would appreciate it. I checked Celebrity's web site and there is no info there. Thanks!
 
Nov 5th, 2002, 09:15 PM
  #2  
Paul Therault
Guest
 
Posts: n/a
Hi Lori,

I do not think you should worry since there has been no problems in quite a few months.

Paul
 
Nov 6th, 2002, 03:20 AM
  #3  
mary
Guest
 
Posts: n/a
Lori: We were on the Summit this past May - - Hawaii to Vancouver. When crossing the Pacific I would have to lean over the side of the ship to make sure we were moving? Very, very smooth.

From what I've heard the pod problem on the Millie class ships seems to have been corrected.

You'll love the Summit!!
 
Nov 6th, 2002, 04:21 AM
  #4  
Susan
Guest
 
Posts: n/a
Lori
My son works on the Summit and there are definitely no problems!
 
Nov 6th, 2002, 05:03 PM
  #5  
DJ
Guest
 
Posts: n/a
A beautiful ship which I am sure you will enjoy. Sailed on it a year ago and there were no problems with the engines as this had already been addressed.
 

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy -

FODOR'S VIDEO

All times are GMT -8. The time now is 10:10 PM.