Forums Help Forums

Post New Topic

Recent Activity

  • Announcements:
  • Forums Style Refresh
    by Emily_D Fodor's Editor | Posted on Apr 27, 15 at 11:33 AM
  • Introducing MeganM
    by Emily_D Fodor's Editor | Posted on Apr 24, 15 at 03:23 PM
View all Forums Help activity »
  1. 1 A bug on Fodors
  2. 2 Problem accessing old trip reports
  3. 3 Forums Style Refresh
  4. 4 My profile picture
  5. 5 How do I log out of Fodor's?
  6. 6 Introducing MeganM
  7. 7 Bad Request Message
  8. 8 Orange globes?
  9. 9 driving to Nh from Orlando Fl
  10. 10 FLASHING ADS…REPEATED SIGNING IN
  11. 11 Trouble posting comments? Please Read
  12. 12 No more trip report symbol?
  13. 13 Infuriating pop up ad for Fodor's emails
  14. 14 torento airport
  15. 15 Double post problem
  16. 16 Please Take Our Survey
  17. 17 Writers Needed for Japan
  18. 18 Search feature doesn't work
  19. 19 discount cruise
  20. 20 Train Fare
  21. 21 Trip Report Trip to Europe from Australia
  22. 22 a different 'glitch'
  23. 23 What's with the Pinterest icons next to many of the Asia threads?
  24. 24 Background ad...
  25. 25 site glitch this evening
View next 25 » Back to the top

Why can't I see the Lounge when I use Google Chrome?

Jump to last reply

When I use Internet Explorer, my long-time browser, I can see the link for the Forums--but if I use Google Chrome, the link for the Lounge doesn't appear. Why not? I don't need to log in with Chrome, but apparently something isn't being recognized.

Advertisement